Search found 140 matches

by smd
Fri Aug 28, 2015 1:44 pm
Forum: Technical
Topic: TWebBrowser, local HTML file and JavaScript
Replies: 9
Views: 43201

Re: TWebBrowser, local HTML file and JavaScript

Try opening your file in your Firefox or Internet Exploder web browser, copy the URL, and paste it in and see if that works.

For example, it takes three slashes for files.

file:///D:/Culinary%20Arts/Site%20Files/blank/index.html

spaces must be %20 and three slashes after file:
by smd
Fri Aug 28, 2015 1:51 am
Forum: Technical
Topic: Which Version Control to use
Replies: 2
Views: 15267

Re: Which Version Control to use

Still poking around at version control systems. Fossil looks interesting. it is the version control used by SQLite developers.

http://fossil-scm.org

Looks simpler than Git and Mercurial. Still investigating....
by smd
Fri Aug 21, 2015 5:07 pm
Forum: Technical
Topic: Which Version Control to use
Replies: 2
Views: 15267

Which Version Control to use

Normally I work alone on my programs. Using a version control system never seemed to be worth the effort. But now I am considering using one. RAD Studio comes with Git, Subversion and Mercurial. I have never used the systems and would like others opinions. 1) What is your opinion regarding using a v...
by smd
Fri Aug 21, 2015 4:27 am
Forum: Technical
Topic: Clearing Clipboard
Replies: 14
Views: 70055

Re: Clearing Clipboard

Sounds like your application has not yet initialized the clipboard for your application since you are trying to clear it at the start of your program. Try doing a simple clipboard operation first that will force the clipboard to initialize. That way the clipboard has something to clear. Below is an ...
by smd
Wed Aug 19, 2015 3:44 pm
Forum: Technical
Topic: XE7 - 'Debug process not initialized'
Replies: 25
Views: 126216

Re: XE7 - 'Debug process not initialized'

One other thing I found. The re-open menu is buggy. I clear it on regular basis. But sometimes it crashes XE8 when I try to clear it. I found by deleting each entry one by one instead of the clear button, then close and restart fixes that problem. I used to run the repair to fix it, which it did, bu...
by smd
Wed Aug 19, 2015 3:21 pm
Forum: Technical
Topic: XE7 - 'Debug process not initialized'
Replies: 25
Views: 126216

Re: XE7 - 'Debug process not initialized'

It really sounds like something in your program, not in XE8, your operating system, or computer. You may be crashing threads that are not getting closed properly, overrunning a buffer causing corrupted data, passing a pointer that points to the wrong thing, not closing files or threads properly, or ...
by smd
Mon Aug 17, 2015 10:08 am
Forum: Technical
Topic: XE7 - 'Debug process not initialized'
Replies: 25
Views: 126216

Re: XE7 - 'Debug process not initialized'

Here is something to try. I had what seemed like random crashes of the system that were not reproducible. I was watching what was going on and noticed that threads were accumulating faster than they were clearing. These were not my threads but threads initiated in the underbelly of the library routi...
by smd
Sat Aug 15, 2015 11:10 am
Forum: Technical
Topic: XE7 - 'Debug process not initialized'
Replies: 25
Views: 126216

Re: XE7 - 'Debug process not initialized'

One other thing I noticed. If I terminate a debug session instead of letting the program end normally, threads get corrupted. Even after exiting and restarting XE8 something is damaged in the operating system requiring a reboot to clear it. Even effects unrelated programs after a full exit from XE8....
by smd
Sat Aug 15, 2015 9:37 am
Forum: Technical
Topic: XE7 - 'Debug process not initialized'
Replies: 25
Views: 126216

Re: XE7 - 'Debug process not initialized'

This sounds like a possible problem with your computer, assuming you have carefully examined you program for memory violations, such as over running buffers or not running as administrator, try examining your computer. Check for crapware running in the background on your computer, do a virus scan, u...
by smd
Tue Aug 11, 2015 4:36 pm
Forum: Technical
Topic: Clearing Clipboard
Replies: 14
Views: 70055

Re: Clearing Clipboard

if (TPlatformServices::Current->SupportsPlatformService(__uuidof(IFMXClipboardService))) { _di_IFMXClipboardService Clipboard = TPlatformServices::Current->GetPlatformService(__uuidof(IFMXClipboardService)); Clipboard->SetClipboard(TValue::From<String>("")); } That worked. No way I would have figur...
by smd
Tue Aug 11, 2015 2:02 pm
Forum: Technical
Topic: Clearing Clipboard
Replies: 14
Views: 70055

Re: Clearing Clipboard

On which platforms? Which version of C++Builder? You should be able to assign an empty string on all of the supported platforms. What exactly happens when you try? What does your actual code look like? Rad Studio XE8 Update 1. My development is currently on Windows 8.1, but I plan to make this a cr...
by smd
Mon Aug 10, 2015 2:37 am
Forum: Technical
Topic: Clearing Clipboard
Replies: 14
Views: 70055

Clearing Clipboard

Using Firemonkey, is there a way to clear the clipboard directly? I thought I saw a clear clipboard command somewhere but cannot find it. All I can find is set and get. So currently I am clearing the clipboard by setting it to a single space character. Tried setting it to an empty string but it does...
by smd
Mon Aug 10, 2015 2:32 am
Forum: Technical
Topic: debug-run crashes without build-all
Replies: 11
Views: 55396

Re: debug-run crashes without build-all

I am not touching windows 10 for at least a few months. Too many issues at the moment, the largest being security issues. Takes 13 screens of settings just to partially disable microsnoops taking and using all your information.

http://www.wired.com/2015/08/windows-10 ... need-know/
by smd
Fri Jul 10, 2015 1:21 am
Forum: Technical
Topic: Open sub-menu from program
Replies: 0
Views: 11008

Open sub-menu from program

Firemonkey XE8 (RAD C++) I cannot seem to find a method to open a menu from the program. I have menu items on the MainMenu of my form which, depending on what is selected, may have one or two levels of child menus that open up. The menus themselves work fine from mouse clicks. The issue is that a co...
by smd
Sun Jun 21, 2015 11:55 am
Forum: General
Topic: XE8 Update 1 Released
Replies: 1
Views: 15698

XE8 Update 1 Released

Here we go again. Another 4 hours of uninstalling and re-installing RAD Studio. The Embarcadero Registered Users Downloads page has three versions depending whether you have an update subscription. Took a moment to figure out. The two versions that require an update subscription, one is if you have ...