Search found 35 matches

by Ahmed Sayed
Thu Nov 15, 2018 3:34 am
Forum: Technical
Topic: Testing TIdHTTPServer in debug mode Win64 issue
Replies: 10
Views: 22933

Re: Testing TIdHTTPServer in debug mode Win64 issue

Thanks Remy for the answer. I know this is not related but how do i configure TIdMimeTable to get mime types from windows registry instead of the hard coded ones. I have seen the delphi source code for the function BuildCache and i think it should work but on windows i always get MIME "image/x-png" ...
by Ahmed Sayed
Wed Nov 14, 2018 3:32 am
Forum: Technical
Topic: Testing TIdHTTPServer in debug mode Win64 issue
Replies: 10
Views: 22933

Re: Testing TIdHTTPServer in debug mode Win64 issue

Yes that's what i am talking about is there a formula that can use or an equation that will give me the required number of servers and how much CPU speed i need for each server? Also, is there a maximum number of requests no matter how powerful the server is that Indy can handle?
by Ahmed Sayed
Tue Nov 13, 2018 3:35 am
Forum: Technical
Topic: Testing TIdHTTPServer in debug mode Win64 issue
Replies: 10
Views: 22933

Re: Testing TIdHTTPServer in debug mode Win64 issue

I will try increasing the ListenQueue as you said but i am talking about service that might receive 100,000 requests at the same time. What is the appropriate amount for any thing not just ListenQueue property. Also, is TIdHTTPServer will be up to the task to handle that big number of requests or do...
by Ahmed Sayed
Sun Nov 11, 2018 3:20 am
Forum: Technical
Topic: Testing TIdHTTPServer in debug mode Win64 issue
Replies: 10
Views: 22933

Re: Testing TIdHTTPServer in debug mode Win64 issue

Thanks Remy, But what i meant with debug mode is I am running the server with the debugger attached (F9). Which makes the server a slower than the running without debugger. Also the server does nothing that serve anything major because all i do is on the server side: //------------------------------...
by Ahmed Sayed
Thu Nov 08, 2018 4:24 pm
Forum: Technical
Topic: Testing TIdHTTPServer in debug mode Win64 issue
Replies: 10
Views: 22933

Testing TIdHTTPServer in debug mode Win64 issue

I am trying to test a simple server that does nothing actually the problem is when i try test the server in debug mode using TIdHTTPServer. I am doing a stress test using a multi-threaded client when i test with requests between 10 and 50. each request is in its own thread i don't get the error ofte...